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Revision history

Registered trademarks
PROFIBUS® 

Registered trademark of PROFIBUS user organization, Karlsruhe Germany

FOUNDATIONTM Fieldbus
Registered trademark of Fieldbus Foundation, Austin, TX 78759, USA

HART® 
Registered trademark of HART Communication Foundation, Houston, USA

ActiveSync®, Microsoft®, Windows®, Windows Mobile® 5.0, Windows 2000®, Windows XP®, 
Windows Vista®, Windows 7®, Windows Explorer®, Internet Explorer® and the Microsoft 
logo are registered trademarks of the Microsoft Corporation.

MACTek® 
Registered trademark of the MACTek Corporation, Ohio, USA

VIATOR® 
Registered trademark of the MACTek Corporation, Ohio, USA

Bluetooth® 
Registered trademark of Bluetooth SIG, Inc, Washington, USA

Acrobat Reader® is a registered trademark of Adobe Systems Incorporated.

FFblue Interface
Softing Industrial Automation GmbH, Germany.

All other brand names and product names are trademarks or registered trademarks of the 
respective companies and organizations.

Product 
version

Manual Changes Comments

1.08.xx1)

1.02.xx2)

BA01211S/04/en/01.13 New Separation of Device Xpert 
software from
hardware manual

1.09.xx1)

1.03.xx2)

BA01211S/04/en/02.14 Addition chapter 3.3.5 and 
3.9 "Additional informations 
for Endress+Hauser devices"

New functionality

1) Device Xpert HART, 2) Device Xpert FOUNDATION fieldbus
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1 Safety

1.1 Designated use

Device Xpert is a device configuration software that is supplied installed on Field Xpert 
SFX 100, SFX350 and SFX370 handheld configurators. Versions are available for both HART 
and FOUNDATION fieldbus. The software can be used for the purposes described in these 
Operating Instructions. Functionality has been tested for devices registered with the HART 
Communication Foundation and the Fieldbus FOUNDATION. There is no guarantee that 
unregistered devices can be configured, although this is often the case. 

1.2 Commissioning and operation

Device Xpert is delivered already installed on a Field Xpert handheld configurator. The 
commissioning and operation of the Field Xpert SFX350 and SFX370 configurators together 
with the associated Bluetooth modems and plant access points is described in Field Xpert 
Operating Instructions BA01202S/04/en and that of Field Xpert SFX100 in Operating 
Instructions BA00060S/04/en.

1.3 Operational safety

Device Xpert is used to configure fieldbus devices. As such it is possible that incorrect 
configurations may lead to unwanted or hazardous situations in a process plant. For this 
reason it is extremely important that the users of the software are adequately trained and 
qualified in commissioning fieldbus devices and have the necessary authorization to do so. 

1.4 Technical improvement

Endress+Hauser reserves the right to make technical improvements hardware and software 
at any time and without prior notification. If such improvements do not affect the operation 
of the device, they are not documented. If the improvements affect operation, a new version 
of the Operating Instructions will be issued.
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1.5 Conventions and icons

In order to highlight safety relevant or alternative operating procedures in the manual, the 
following conventions have been used, each indicated by a corresponding icon in the margin.

Safety conventions

Icon Meaning

DANGER!
This symbol alerts you to a dangerous situation. Failure to avoid this situation will 
result in serious or fatal injury.

WARNING!
This symbol alerts you to a dangerous situation. Failure to avoid this situation can 
result in serious or fatal injury.

CAUTION!
This symbol alerts you to a dangerous situation. Failure to avoid this situation can 
result in minor or medium injury.

NOTE!
This symbol contains information on procedures and other facts which do not 
result in personal injury.
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2 Function and System Design

2.1 Function

Field Xpert from Endress+Hauser is a high-performance industrial mobile computer (PDA) 
based on Windows Embedded Handheld, with compact external dimensions, an integrated 
WLAN, USB, Bluetooth and infrared connection. This allows it to be connected to HART and/
or FOUNDATION fieldbus devices via a modem or gateway. With a range of Ex approvals, 
Field Xpert meets the needs and requirements of the process industry for applications inside 
and outside hazardous areas. 

Once the Field Xpert hardware and the Device Xpert software are communicating with a 
device, it can be parameterized. Depending upon the system architecture, only one device 
may be seen, e.g. in HART point-to-point or all the devices connected to the segment, e.g. in 
FOUNDATION fieldbus applications.

Fig. 2-1: Device Xpert FOUNDATION fieldbus start page and live list of connected devices

Other functions Other functions, described in more detail in Chapter 3 are:

�  Device Description (DD) updates
�  Envelope curve 
�  Favorites folder
�  Search function
�  Device diagnosis
�  Upload/Compare function
�  Device Report (XML)
�  Application help
�  Generic DD
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2.2 Connecting to HART devices

WARNING!
� Proof of intrinsic safety must be checked when additional devices are introduced into a 

loop.

2.2.1 VIATOR Bluetooth modem

The VIATOR Bluetooth modem allows point-to-point connections to be made with a HART 
device. There are two possibilities of making it:

�  For a normal transmitter power supply, e.g. RMA42, via a 270 load resistor (250 – 
1100 ) connected into the loop as shown in Fig. 2-2

�  With a transmitter power supply with built-in HART communication resistor, via the 
two HART communication sockets on the front panel as shown in Fig. 2-3. Suitable 
HART transmitter power supplies are: 
– RNS221, RMA422, for non-Ex applications
– RN221, RMA421 for Ex and non-Ex applications

The connection between the Field Xpert and the modem is wireless (Bluetooth).

NOTE!
� The modem is certified for use in hazardous areas, Zone 1. Once a modem has been used 

in a non-Ex installation, it should never be used in an Ex installation, as there is a danger 
that the protective circuits have been inadvertently overloaded and no longer function 
correctly.

Connection via a load 
resistor

Fig. 2-2: Connection via load resistor

Connection via HART 
communication sockets

Fig. 2-3: Connection via a transmitter power supply with HART communication sockets (internal load resistor)

+

-

+

-
HART device

Transmitter
power supply
e.g. RMA42

Load resistor
250 - 1100 Ohm

VIATOR Bluetooth modem Field Xpert

Transmitter
power supply 
RMA421
RMA422
RNS221
RN221N

–

+

HART device

VIATOR Bluetooth modem Field Xpert
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2.2.2 WiFi – HART point-to-point connection via Fieldgate

Two HART devices can be connected directly to the input channels of the Fieldgate FXA520. 
If the appropriate version of Fieldgate was ordered, the devices can be used in hazardous 
areas. The inputs meet the requirements of SIL 2 for 4 to 20 mA loops (IEC 61508). 
Fig. 2-4 shows the equipment architecture, whereby the Field Xpert communicates with the 
Fieldgate via a WiFi access point and the Fieldgates are powered by RN221 or RN221N-B 
transmitter power supplies.

Fig. 2-4: Equipment architecture for HART point-to-point connection

2.2.3 WiFi – HART multidrop connection via Fieldgate

With the FXN520 multidrop module, up to 2x 8 HART devices operating in a non-hazardous 
area, can be connected to the Fieldgate. Fig. 2-5 shows the equipment architecture.

Fig. 2-5: Equipment architecture for HART multidrop connection
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2.2.4 WiFi – HART multiplexer connection via Fieldgate

Fig. 2-6 shows the equipment architecture for an HART multiplexer connection. The RS-485 
interface for Fieldgate FXA520 can be used for connecting up to two HART multiplexers, e.g. 
the KFD2-HMM-16 from Pepperl+Fuchs. Up to 30 HART devices can be connected in this 
way. If the devices are used in a safe area, the RNS221 transmitter power supply can be used 
to power two devices. Ex devices can also be installed in hazardous areas. In this case, the 
signal must be connected to the safe side of a RN221N-B transmitter power supply.

Fig. 2-6: Equipment architecture for HART multiplexer connection
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2.3 Connecting to FOUNDATION fieldbus devices

WARNING!
� Proof of intrinsic safety must be checked when additional devices are introduced into a 

loop/segment.

2.3.1 FFblue Bluetooth modem

Field Xpert communicates with a FOUNDATION fieldbus device via the FFblue Bluetooth 
modem. The connection between the Field Xpert and the modem is wireless. The modem can 
be connected at any point on the H1 fieldbus segment, or directly to the fieldbus terminals 
of the device itself. The modem can also be used in explosion hazardous areas, provided that 
the Field Xpert used with it is also certified for Ex applications.

Fig. 2-7: Connection of FFblue modem to FOUNDATION fieldbus H1 segment

2.3.2 WiFi – FOUNDATION fieldbus connection via gateway

Fig. 2-8 shows the equipment architecture, whereby the Field Xpert communicates with the 
SFC162 gateway via a WiFi access point. The SFC162 gateway is connected in parallel to the 
controller. It has four channels, each of which may be connected to a different FOUNDATION 
fieldbus H1 segment.

Fig. 2-8: Equipment architecture for FOUNDATION fieldbus network (Non-Ex)
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3 Operating Field Xpert

3.1 Getting Started

3.1.1 Connections

NOTE!
� The commissioning of Field Xpert is described in Operating Instructions BA01202S/04/en

Bluetooth connections Before Field Xpert can be used to configure HART or FOUNDATION fieldbus devices it must 
be commissioned. What exactly must be done depends upon the type of connection that is 
in use and the license that has been purchased. In general:

�  a Bluetooth connection for HART has already been configured and installed in Field 
Xpert by Endress+Hauser prior to delivery if a HART or HART plus FOUNDATION 
fieldbus Device Xpert license has been purchased

�  a Bluetooth connection for FOUNDATION fieldbus has already been configured and 
installed in Field Xpert by Endress+Hauser prior to delivery if a FOUNDATION fieldbus 
or HART plus FOUNDATION fieldbus Device Xpert license has been purchased

�  a WiFi connection must always be configured and installed by the user

The user may also need to configure and install a Bluetooth connection if the license is 
upgraded or if the modem needs to be reconfigured following a Field Xpert clean reset. This 
procedure is described in Field Xpert Operating Instructions BA01202S/04/en.

WiFi connections If a WiFi connection to a Fieldgate FXA520 (HART) or SFC162 gateway (FOUNDATION 
fieldbus) is to be used, then the connection must be set up before the associated Device Xpert 
software can be used, see Field Xpert Operating Instructions BA01202S/04/en

NOTE!
� The VIATOR HART Bluetooth modem switches off if there is no traffic for 30 minutes, and 

must be switched on again to reactivate it
� The FFblue modem switches off if there is no traffic for 10 minutes and must be 

reconnected to the bus to switch it on again
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3.1.2 Power up

1. If you are using the Fieldgate FXA520 or SFC162 gateway, check that the devices are 
powered up and that the network is up and running

2. Switch on Field Xpert 
(switches on automatically when the USB connector is inserted into the computer)

3. The Field Xpert home screen appears:
– Check that the correct communication mode is active
– To change mode tap on the communication icon to open the Wireless Center screen

and activate the mode required by a tap on the appropriate button, see Field Xpert 
Operating Instructions BA01202S/04/en for more details of wireless set-up

4. Tap on the Device Xpert software version you require

5. The start screen of Device Xpert version selected appears:

NOTE!
� By tapping the windows icon located on the navigation bar in the Device Xpert home 

screen, the Operating System minimizes Device Xpert and returns to the Windows 
Operating system.

� Device Xpert is minimized only and continues to run in the background.



Operating Field Xpert Device Xpert

12 Endress + Hauser

3.1.3 Synchronize the DD library (DD updates)

Device Xpert is supplied with the latest set of HART and/or FOUNDATION fieldbus device 
descriptions (DDs) available at the time of factory configuration. For a period of 60 days after 
this time or longer if an optional DD updating licence (Software Update Service) has been 
purchased, Device Xpert will connect to the Endress+Hauser Field Xpert - Device Xpert DD 
Update Server, where the latest DD libraries are available. Device Xpert automatically detects 
whether a valid licence is available, e.g. if purchased at a later date or updated. It is 
recommended that the library is synchronized during the initial setup of the device, then at 
regular intervals thereafter (if the Software Update Service is licenced).

Updating the DDs in 
Device Xpert

To update your DD device library, the Field Xpert must be connected to the internet. This can 
be done either:

�  directly via a WiFi connection or 
�  via a USB or Bluetooth connection with your laptop/PC. 

To activate the license via a Bluetooth or USB connection, you will need Windows Mobile 
Device Center (Windows 7) or ActiveSync Version 4.5 of higher (Windows XP). Please check 
if Windows Mobile Device Center or ActiveSync is installed on your PC. If not, download 
Windows Mobile Device Center or ActiveSync from the Microsoft web site and install the 
software package.

Depending on the type of connection you have selected, connect the USB cable to your Field 
Xpert docking station and a free USB port on your PC or activate the Bluetooth interfaces at 
the PC and Field Xpert.

The following steps are independent of the connection type and therefore apply equally to 
all of the internet connections described above.

1. Start Windows Mobile Device Center/ActiveSync

2. If Field Xpert is to access Internet via a proxy server, enter the appropriate server 
parameters, see Chapter 3.10.3

3. Start Device Xpert and select Device=>Synchronize Library.

4. Synchronization starts and Device Xperts checks automatically if there are new DDs
– If there have been no updates since your last connection, a message will be displayed

5. Confirm the synchronization by Tapping on Yes
– The download starts automatically

6. After download, you are ready to use the new device descriptions
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3.1.4 Update your personal licence details

Field Xpert is delivered with a licence filled with factory default values for name and e-mail. 
We suggest that you fill in your company or name and contact e-mail address. 

1. From Device Xpert HART or Device Xpert FF select Help=>Maintain Licence

2. Tap on the keyboard at the bottom of the dialog and fill in your contact details 
– Enter company/name and e-mail address
– Enter your password, to be found on the rear of the CD-ROM supplied
– Tap on Refresh to confirm the changes

3. The licence information is shown at the at the top and bottom of the screen
– Product: software package licenced on the Field Xpert
– Device Xpert Software Licence Number
– Activated on: date on which the licence was activated
– DD Updates until: last date at which updates can be downloaded, see Chapter 3.1.3
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3.2 Connecting to a HART device

Device Xpert HART is configuration software for device commissioning, diagnosis and 
maintenance of HART devices that are registered at the HART Communication Foundation. 
It is available in English and German language. Device Xpert HART enables automatic 
scanning of the HART network as well as quick and easy configuration and diagnosis of the 
available devices.

1. Check that your Field Xpert is switched on and has an active Bluetooth or WiFi 
connection

2. Start the Device Xpert HART software by tapping on its icon on the Field Xpert start 
screen

3. From the Device Xpert HART start screen select Device => Scan 
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4. In the Initate Device Scan menu
– Check that the Connection is set to the correct modem or gateway

– Opening the Connections tab and tapping on an icon changes the connection
– By default the address range is 0 to 0, which corresponds to a 4–20 mA/HART

signal
– For HART multidrop, set the address range to cover all HART polling addresses

used.
– If there is a HART primary master in the loop, tap on (check) the Secondary box.

– Tap on the Scan button

5. Device Xpert now searches the connected network for HART devices and automatically
assigns the appropriate device driver (DD) to the connected devices
– For 4–20 mA/HART the parametrization overview page is shown, see Step 6
– For HART multidrop or Fieldgate FXA520, several devices may be found
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6. Tap on a device name to open the parametrization overview page:

3.3 Connecting to a FOUNDATION fieldbus device

Device Xpert FF configuration is software for device commissioning, diagnosis and 
maintenance. It is available in English and German language and supports FOUNDATION 
fieldbus devices that are registered at the Fieldbus Foundation. Device Xpert FF enables 
automatic scanning of the FOUNDATION fieldbus network as well as quick and easy 
configuration and diagnosis of the available devices.

3.3.1 Generate a live list

1. Check that your Field Xpert is switched on and has an active Bluetooth or WiFi 
connection

2. Start the Device Xpert FF software and select Device => Scan 
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3. In the Initate device Scan menu
– Check that the Connection is set to the correct modem or gateway

– Opening the Connections tab and tapping on an icon changes the connection
– Tap the Scan button

4. Device Xpert now searches the connected network for FOUNDATION fieldbus devices 
and publishes a live list
– Example via SFC162 gateway left, via FFblue modem right
– For uncommissioned devices, the device name and identifier normally appears

5. For commissioned devices, a block and parameter list can now be generated as described 
in Chapter 3.3.4
– For uncommissioned devices, continue with Chapter 3.3.2.
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3.3.2 Setting a tag and device address

NOTE!
� This function is primarily for commissioning of individual devices which are connected 

point-to-point with a modem or gateway, i.e. test bench operation.
� Device Xpert identifies commissioned devices and deactivates the corresponding menu 

items

1. Tap and hold on a device
– In the context menu that appears: Tap on Tag/Address=> Set Tag

2. Enter the tag, Tap OK to register the change 
– Tap on OK to acknowledge the message that appears: 
– The new tag is displayed in the tree

3. Tap and hold on a device
– In the context menu that appears: Tap on Tag/Address=> Set Address
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4. Select the address from the drop-down menu, enter it or use the slider
– Tap on the checkbox Decimal to change from hexadecimal to decimal addresses
– Addresses from 0x10 (16) to 0x13 (19) are reserved for Bridges

Addresses from 0x14 (20) to 0xF7 (247) are reserved for field devices, whereby any
device with BOF Class "Link Master" should have a lower address than a device with 
BOF Class "Basic"
A compact address range accelerates the scanning of the segment

– Tap on OK to register the change and download the address to the device 
(takes time)



Operating Field Xpert Device Xpert

20 Endress + Hauser

3.3.3 Setting a BOF Class

If the device is to be assigned link master functionality, the BOF Class can now be changed 
to "Link Master". Normally only one field device in an H1 segment will be allocated this 
functionality. Not all devices support Link master functionality.

1. Tap and hold on the device
– In the context menu that appears: tap on BOF Class => Set Link Master

2. In the dialog that now appears, tap on OK, to confirm the change

3. Tap and hold on the device
– In the context menu that appears: Tap on Restart Device
– In the dialog that now appears, tap on OK, to confirm the restart
– When the device has restarted the "Link Master" functionality is activated
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3.3.4 Generate a block and parameter list

1. In the live list, tap and hold on a device to open the context menu
– Select Fetch Block List to load all the blocks from the selected device

Alternatively, tap on a device and Tap OK, the blocks are loaded in the scan page

2. Now tap on the block you wish to open
– The block opens: if necessary open the tree to show the menu items
– To return to the block list tap on Device => Disconnect Block

NOTE!
�  Depending on device DD, it is possible that not all input parameters are visible in their 

own block. The block Parameters, however, contains all the parameters in the device 
not contained in menu items.
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3.3.5 Activate and deactivate reduces view

Some field devices support reduced menu views that are adjusted specifically to handheld 
configurators. For these field devices, the reduced view is shown by default.

To display all menus and parameters available in the device description

1. Tap and hold the block name in the tree view until the context menu is shown

2. Select Display All Menus to show all menus and parameters that are defined in the 
device description

NOTE!
� The above option is deactivated and all menus and parameters are shown if the DD for a 

specific field device does not contain such a view adjusted for handheld devices.

3.3.6 Change the block target mode

In general, the parameters of a FOUNDATION fieldbus transducer block can only be changed 
when the block is out of service (OOS). Depending on how you have chosen to generate your 
parameter list, this can be done from the live list, the block list or the parameter list. After 
all parameters have been changed and downloaded, the block target mode must be set to 
Auto again.

1. All blocks in the selected device can be put out of service by putting the resource block 
out of service in the live list
– From the live list tap and hold on the resource block and select Set Target Mode 

from the context menu
– Alternatively, from the block list tap on OOS in the block mode header
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2. In the page which appears:
– Remove the tick from Auto and tick OOS
– Tap on OK to execute the change

3. An individual block can be put out of service in the same manner as above by selecting 
the block in the live list
– Tap and hold on the block and select Set Target Mode from the context menu or 

from the block list tap on OOS in the block mode header
– In the page which appears, see Step 2, remove the tick from Auto and tick OOS
– Tap on OK to execute the change

4. If supported, an individual block can also be put out of service in the parameter list
– Open the parameter group Process (name may differ according to device) or

Parameters 
– In the parameter list, open the Block Mode=>Target parameter
– Set the value to OOS
– Tap on the yellow arrow and if necessary confirm with Yes to execute the change

5. Put the blocks back into operation as in Steps 1 to 4 above, but select the option Auto
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3.3.7 Enable function block viewing

Normally Device Xpert is not used to configure function blocks: this task is done in the 
engineering software for the DCS in use. For this reason, the default setting for Device Xpert 
is to hide the corresponding information. If you wish to see the function blocks in the block 
list, they can be enabled as follows.

1. From the Device Xpert start page select View => Configuration

2. Scroll to the Options tab using the arrows in the corner of the Configuration dialog.

3. Tap on the Options tab
– Tap on the check box Enable Function Blocks to enable viewing
– Tap on OK to confirm the setting and close the dialog
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4. The function blocks will now appear in the block list.
– If you activate this function after you have already fetched the function blocks of a

device, you will have to repeat the Fetch Function Block command, see Chapter 3.3.4

3.4 Parameterization of devices

NOTE!
� FOUNDATION fieldbus blocks must be put out of service (Target Mode = OOS) before any 

parameter changes can be downloaded to the device, see Chapter 3.3.5.

The parameters offered by a device depend upon its manufacturer, type and function. For 
this reason it is not possible to describe how a particular device is parameterized in order that 
it functions properly - here the user is referred to the device’s operating manual. It should 
also noted that not all the functions described in this chapter are available in all devices.

3.4.1 Parameter folder tree

All parameterization starts at the parameter folder tree (HART, left) or block folder tree 
(FOUNDATION fieldbus, right) which is read from the Device Description (DD) of the device. 
The table below lists the most important features of the parameter tree page:
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The header bar of the parameter tree can be hidden/displayed by selecting View=>Header 
Bar.

3.4.2 Parameter folders

The parameter folders group together input and output parameters associated with 
particular device functions. The table below lists the most important features of the 
parameter tree page:

Item Function Remarks

1 Tag name � HART: Tag name read from the connected device
� FOUNDATION fieldbus: Block name

2 Header bar For HART devices (as shown left)
� Loop current (in the example the device is HART 4–20 mA)
� Primary value (in the example level in percent)

For FOUNDATION fieldbus devices (as shown right)
� Primary value (in the example percent)
� Block target mode (permitted in black, actual with green background)

3 Parameter group folder � Tap on the node to open the folder and display the associated 
parameters, see Chapter 3.4.2

� For FOUNDATION fieldbus, if the input parameters are not available in 
their own subblock, the block "Parameters" contains all said parameters 
for the block.

4 Expansion/contraction 
point

� "+" expands the tree to show the parameters beneath the node
� "–" contracts the tree to hide the parameters beneath the node

5 Customized parameter 
folder

Folder in which a customized view of the device parameters can be stored

6 Connection status Status indicating whether the device is online or offline

7 Keyboard � Tap on the icon to show the keyboard
� Tap on the icon when the keyboard is active to hide it again

8 Search � Tap on the icon to open the search function
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Item Function Remarks

1 Horizontal navigation Indicates the current position in the navigation tree
� A tap on the higher level closes the current level and moves upwards

2 Vertical navigation Navigates between parameter group folders
� Arrow up: moves to and opens the parameter group folder above
� Arrow down: moves to and opens the parameter group folder below

3 Device parameter Current value of a device parameter
� Tap on the parameter to change the setting

– Normal parameters can be changed
– Grey parameters are read only and cannot be changed
– Red parameters have not been accepted by the field device

4 Device parameter name Designation of parameter, select to open context menu, see below
� Normal parameters can be changed
� Bold parameters have been changed in this session
� Grey parameters are read only and cannot be changed

Tap and hold parameter to open the context menu for the parameter
� Display Help: display the help text for the parameter
� Show Valid Range: Display the range of valid parameter values
� Refresh Value: causes the value to be read from the device again
� Refresh Group: causes the parameter group to be read from the device 

again
� Refresh Vars On/Off: Toggles the automatic refresh of the selected 

value
� Display Error: displays a parameter error
� My <Device> or My Block: Adds the selected parameter to be added to 

the customized parameter folder
– Select my device – a submenu "Add" appears
– Select Add

5 Parameter help
available

Yellow triangle indicates that the parameter has an online help, see 
above

6 Confirm updates Transfers all updates made in the folder to the field device

7 Discard updates � After confirmation with YES, discards all updates made since last edit
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3.4.3 Device diagnosis (NAMUR NE107)

Device Xpert HART and FOUNDATION fieldbus have an option which provides information 
on the health status of the connected field device. Five different status conditions can be 
displayed, notifying the user if for example the field device is malfunctioning or a service is 
needed etc. The corresponding health status icon is displayed top right in the device 
parameter window.

NOTE!
� Not all field devices are capable of supporting this functionality. 
� FOUNDATION fieldbus does not support this functionality for all block types.

1. Tap on the symbol in the top right hand corner to display the diagnosis information

Icon Meaning Description

Failure The field device has malfunctioned such that one or more device 
variables (i.e. measurement or control) are invalid or inaccurate

Function Check The field device is being serviced and one or more device variable 
values may be (temporarily) frozen or invalid

Out of Specification One or more device variable values may have been compromised due 
to past or present ambient/operating conditions deviating from 
device requirements

Maintenance Required To ensure continued proper operation maintenance must be 
performed on the field device

OK The field device is operating correctly
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3.4.4 Block/device and parameter diagnosis

The block status information of FOUNDATION fieldbus devices and device status 
information of HART devices not supporting NAMUR NE107 can be also be shown using the 
View menu. Incorrectly configured parameters can also be diagnoses using the Display Error 
function. 

1. For FOUNDATION fieldbus select View=>Block Status
For HART select View=>Device Status

2. Parameters in the parameter list which are permanently displayed in red have an error
– Open the parameter error description by tap and hold on the parameter name and 

selection of Display Error
– A text box with a description of the error appears
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3.5 Envelope curve

Device Xpert provides an envelope curve display for all Endress+Hauser time-of-flight level 
transmitters using the HART protocol. It is added as an Envelope Curve parameter group in 
the parameter group tree. For a full description of the functions, the user is referred to the 
operating instructions of the connected device. 

1. From the device parameter group tree tap on Envelope Curve

2. In the parameter page set the parameters as required 
(example only, see operating instructions of connected device for more information)
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3. When the parameters have been changed, download them to the device by tapping on 
the yellow tick at the bottom of the page
– Confirm the download with Yes

Parameter Significance

Curve Type Determines the type of curve to be sampled
� Envelope
� FAC
� MAP
� Envelope + FAC

Start Curve Value Value in meters from the probe head, at which the envelope sampling should start

End Curve Value Value in meters from the probe head, at which the envelope sampling should end

Sample Resolution Determines the resolution of the curve
� Low
� Low-Medium
� Medium
� Medium-High
� High

Execute Curve Tapping on Execute starts the sampling process



Operating Field Xpert Device Xpert

32 Endress + Hauser

4. Tap Execute to start the sampling
– If necessary, confirm that the Device Xpert will wait for any pending updates 

with Yes
– The envelope curve is sampled and displayed (may take several minutes)

5. Tap and hold on the graph opens a context menu that allows the user to
– Change the presentation (FAC, Envelope)
– Hide the display legend or move it to a bottom left (or top left)
– Have a Zoom View/Small View of the envelope curve
– Close the envelope curve (Close Graph)
– Create an Envelope Report, see Chapter 3.8.2
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3.6 Favorites folder

In every device description there is a Favorites folder with the name My <device name> 
(HART) or My Block (FOUNDATION fieldbus). Here you can put all of the parameters which 
you would like to have immediately to hand. It is also possible to group the parameters in 
different subfolders.

Adding a folder 1. Tap and hold on the My <device name>/My Block folder to open the context menu

2. Tap on Add Folder to open the Enter Folder Name page
– Display the keyboard by tapping on its icon

3. Enter the name and tap on OK to add the subfolder to My <device name>/My Block
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Adding parameters 4. Open the parameter group folder containing the parameter that you want to add 
– Tap and hold on the parameter name you want to store until the context menu

appears
– Select My <device name>/My block then Add or <Subfolder>=>Add
– Confirm with OK
– The parameter is added to the My <device name>/My Block folder or the subfolder

5. Display the parameters by opening the My <device name>/My block folder or 
subfolder

6. Parameters can be removed from the My <device name>/My Block folder by calling the 
parameter context menu by tap and hold and selecting Remove from "My <device 
name>/My Block" or Remove from "<Subfolder>"
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3.7 Upload/Compare function

The Upload/Compare function enables HART device configurations to be saved in the form 
of an offline, upload image in the Field Xpert. Using such an image, the current device 
configuration can be easily viewed, compared with and verified against previous device 
configurations.

3.7.1 Upload

1. Upload the current image of the connected device by selecting Device=>Upload/
Compare
– Select Device Image Upload
– Answer Yes to the device requery message which now appears

2. In the page which now appears enter the file storage information:
– Default file name is tag, date and time of day (can be changed)
– Tap on OK to store

3. Field Xpert uploads the current device configuration and stores it as an .img file at the 
location \SD Card\IMAGES:
– A successful upload is indicated by a corresponding message.
– Tap on OK to confirm
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3.7.2 Compare

1. Open the upload image file with which you want to compare the current device 
configuration by selecting Device=>Upload/Compare
– Select Open Upload Image

2. In the Open page which now appears
– Tap on the file you wish to open
– If the file name cannot be read, turn the Field Xpert SFX350/370 to landscape view

(for Field Xpert SFX100, press the F1 key for a couple of seconds to toggle between
portrait and landscape view)

– The column width can be adjusted by dragging the cursor over the separating line 
(as done in Excel)
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3. The image file is opened in a new tab
– Historical parameter settings can be seen by navigating through the parameter

groups

4. To compare the online configuration against the previously stored image, select 
Device=>Upload/Compare
– Select Compare (only possible if image tab is selected)

– Answer Yes to the device requery messages which now appear

5. After comparison, a compare message informs of changes
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6. Tap on OK to display the compare parameter tree
– Parameter groups and parameters with differences are highlighted in red

NOTE!
� The compare function does not differ between dynamic (output) and static parameters, so 

that it is normal to find differences between parameter groups

7. Tap on a highlighted folder to see the changes in detail

8. Tap and hold on a highlighted parameter to see the online configuration value

– Reset Comparison Results removes the highlighed comparison results
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9. Close the image by selecting Device=>Upload/Compare=>Close
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3.8 Device and Block Reports

3.8.1 Create Device Report (Device Xpert HART)

For documentation purposes, you can create a report of the online device configuration and 
save it on your PDA. 

1. To create a report of the device configuration select Device=>Create Device Report

2. In the page which now appears enter the file name
– Default file name is tag, date and time of day (can be changed)
– Tap on OK to store

3. Field Xpert stores the current device configuration as an XML file with XSL style sheet at 
the location \SD Card\REPORTS
– A successful save is indicated by a corresponding message
– Tap on OK to confirm

4. The Device Report can be viewed with Internet Explorer on the PDA or PC. On the PC it is 
possible to import it into Excel
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3.8.2 Create Envelope Report (Device Xpert HART)

The envelope curve graph, see Chapter 3.5, can be saved as an image. 

1. To create a report (image) of an envelope curve, tap and hold on the envelope curve tab 
and then tap on Create Envelope Report. 

2. In the page which now appears enter the file name
– Default file name is tag, date and time of day (can be changed)
– Enter any comments in the comments box
– Tap on OK to store

3. Field Xpert stores the report as an XML file with XSL style sheet at the location \SD 
Card\REPORTS
– A successful save is indicated by a corresponding message
– Tap on OK to confirm

4. The Envelope Report can be viewed with the Internet Explorer on the PDA or PC. On the 
PC it is possible to import it into Excel
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3.8.3 Create Block Report (Device Xpert FF)

For documentation purposes, you can create a report of the online FOUNDATION fieldbus 
block configuration and save it as an XML file on your PDA. 

1. To create a report of the block configuration select Device=>Create Block Report
when the block you require is connected

2. In the page which now appears enter the file name
– Default file name is tag, block, date and time of day (can be changed)
– Tap on OK to store

3. Field Xpert stores the current block configuration as an XML file with XSL style sheet at 
the location \SD Card\REPORTS
– A successful save is indicated by a corresponding message
– Tap on OK to confirm

4. The Block Report can be viewed with the Internet Explorer on the PDA or PC. On the PC 
it is possible to import it into Excel
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3.8.4 View reports on PDA

1. Tap on Reports in the start screen

2. In the folder that opens tap on the desired report
– If the file name cannot be read, turn the Field Xpert SFX350/370 to landscape view

(for Field Xpert SFX100, the F1 key toggles between portrait and landscape view)

3. The XML report (HART left, FOUNDATION fieldbus right) is displayed with Windows 
Internet Explorer using the style sheet (here shown in landscape mode and smallest 
font)

– Scroll down to see more information



Operating Field Xpert Device Xpert

44 Endress + Hauser

3.8.5 Backup/Copy reports and images

By using an Windows Mobile Device Center or ActiveSync connection from Field Xpert to 
your PC or laptop, it is possible to view and back up device reports and images.

1. Make sure that the Windows Mobile Device Center or ActiveSync connection is up and 
running

2. Start Windows Explorer on the PC or Laptop

3. Navigate to the SD-card in the Mobile Device folder

4. The device configuration images and device reports are to be found in the IMAGES and 
REPORTS folders

5. Copy the desired files including the XSL style sheet to the PC or laptop in a separate 
folder

3.8.6 View report on PC/laptop

The reports can be viewed by opening the required report file using the Internet Explorer. 
Note that the style sheet needs to be in the same folder as the report.
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3.9 Field Device Documentation

Device Xpert HART and Device Xpert FF allow the user to download and display the 
supporting documentation of Endress+Hauser field devices. These additional,
device-specific documents may include operating instructions, safety instructions and 
technical informations.

3.9.1 Search for device documents

1. Tap on View and Device Documentation

2. Enter the serial number of your selected field device into the serial number entry box. 
Then tap on the magnifyingPglass button

NOTE!
� While entering the serial number, Device Xpert compares the part of the serial number 

already entered with field devices you have recently viewed.
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3. Device Xpert verifies that a connection to the Internet can be established and that the 
serial number you entered is valid. You will then be asked whether you would like to 
download all documents available for this device. Select Yes to continue.

NOTE!
� If you select No or if a connection to the Internet could not be established, you may tap 

Yes in response to the subsequent question to save the serial number for future 
document retrieval (see Chapter 3.9.2).

3.9.2 View field device documents

1. Tap on one of the stored serial numbers
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2. Tap on the document you would like to view

3.9.3 Managing the list of stored devices

Download Documents 1. Tap and hold a serial number. Select Download to download all available documents for 
this device

NOTE!
� Available documents are downloaded if an Internet connection can be established.
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Update Documents 2. Tap and hold a serial number for which documents have already been downloaded, and 
select Update

NOTE!
� Available documents are downloaded if an Internet connection can be established.

Delete Documents 3. Tap and hold a serial number, and select Delete

4. Confirm the following question with Yes if you want to delete the documents
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Download all outstanding 
Documents

5. Select Download Outstanding Documents to retrieve all documents that have not 
previously been downloaded.

NOTE!
� Available documents are downloaded if an Internet connection can be established.



Operating Field Xpert Device Xpert

50 Endress + Hauser

3.10 Additional functions

3.10.1 Search function

If the position of a specific parameter or special function in the device description is 
unknown, it can be found by using the integrated search function. 

1. Select the magnifying glass icon in the lower menu bar

2. In the search page, enter the parameter name you wish to search for (or part of it) into 
the text field and then tap on Search

3. You will be provided with a list of all parameters containing your search term.
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4. Tap on the parameter to jump to the parameter folder
– The parameter searched for is highlighted in yellow

5. Tap on the magnifying glass to return to the search list, see Step 3

6. To delete the search result, tap and hold on a parameter
– In the context menu tap on Clear Search Results

7. The parameters are displayed as normal:
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3.10.2 Application help

Device Xpert possesses an application help in which detailed information is available. 

1. Open the application help by selecting Help=>Application Help

2. The list of topics appears
– Tap on the topic you require 
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3.10.3 Device information (HART)

Device Xpert HART offers an overview of the device information

1. To open a device information page:
– Tap and hold on the device line and select Device Information from the context

window
– or select View=>Device Information from the main menu

2. The device information is displayed

3. Close the Device Information page with OK
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3.10.4 Device information and block properties
(FOUNDATION fieldbus)

Device Xpert FF offers an overview of the device information and block properties

1. To open a device or block properties page:
– Tap and hold on the device or block line
– Select Device Information or Properties from the context window

2. The device information or block properties are displayed
– Example: device left, block right

3. Close the Device Information or Properties page with OK
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3.10.5 Device Description information

Information on the device descriptions held by the device can be obtained as follows:

1. In the block list, tap on View => Device Description Info

2. The device description information for the device online is displayed

3. Tap on OK to close the dialog

3.10.6 Generic DD

Device Xpert HART supports the HART Generic DD. This feature ensures that Field Xpert user 
can perform a basic configuration of a HART Device, even when the specific Device 
Description is not available in Field Xpert.

1. Open Device Xpert and open the Scan page with Device=>Scan

2. In the Scan menu tap on Scan

3. When the device has been found, tap on its name

4. If Field Xpert is unable to find a registered DD, it will automatically load the Generic DD
– Confirm possible messages with Yes or OK
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3.11 Configuration menu

Device Xpert HART and Device Xpert FOUNDATION fieldbus have a configuration menu, 
under which all configuration dialogs are grouped. Some are called during commissioning 
and some offer additional options or device information. The menu is called by selecting 
View => Configuration.

The Configuration dialog has a number of tabs which can be selected by tapping directly on 
them. The arrows on the bottom righthand side allow navigation to hidden tabs.

3.11.1 Connection

The Connection dialog shows the connections that are available for Device Xpert (HART left, 
FOUNDATION fieldbus right). 

1. Tapping on Add Connection allows a new connection to be set up, see Field Xpert 
Operating Instructions BA01202S/04/en.

2. For HART devices, tap and hold on a connection icon and subsequent selection of the 
Properties menu reveals a page with:
– Default Master Operation mode
– Default Address Range 
– Automatic scan option, see Chapter 3.10.2
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3.11.2 Automatic HART scan

For Device Xpert HART, automatic scanning can be set up in the Connection menu as 
follows:

1. Tap and hold on the Bluetooth or Fieldgate FXA520 connection and select Properties
– The Connection Configuration menu appears:

2. Tap on the Automatic checkbox to enable automatic scanning
– If necessary, set up the scan range as described in Chapter 3.2.
– Press OK to store the changes and return to the scan page

3. After the initial set up, the scan must be started with the Scan button
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4. On all subsequent openings of the Scan menu, the device scan is made automatically
– Parameters can still be changed during the scan, but the Restart Scan button must

be tapped to start a scan with the new parameters

3.11.3 HTTP Proxy

The HTTP Proxy dialog is required if Field Xpert is to access Internet via a proxy server.

1. Activate the dialog by tapping on the checkbox Activate HTTP Proxy

2. Enter the data required for your proxy

3. Tap on Test the proxy settings to check that Internet can be accessed
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3.11.4 Device library

The Device library dialog shows a list of all the DDs (HART or FOUNDATION fieldbus) 
supported by Device Xpert. The tree can be opened out to reveal the device names and DD 
versions.

Tap and hold on any folder to get additional information via the context menu.

3.11.5 Paths

The Paths dialog displays the paths where the Device Xpert program and DDs are stored. It 
also controls the logging function for Field Xpert. When activated, the logs are to be found 
in \Programs\DeviceXpert\log_hart.txt or log_ff.txt.
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3.11.6 Options

The Options dialog controls the various Device Xpert functions, e.g. whether "My <Device>/
My Block appears in the device or block list of a HART or FOUNDATION fieldbus device.

3.11.7 Modem

The Modem dialog lists the Bluetooth modems that are currently paired with Field Xpert and 
allows the default modem for the current application to be selected.

The screen also contains information about the connected modem, including the firmware 
version and battery level of the used modem.
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4 Troubleshooting
We expect our hardware and software products to function without any problems. 
Nevertheless, we are unable to provide a 100% guarantee that this will be the case. For this 
reason, here are some tips and solutions for dealing with possible faults.

4.1 Reinstalling Device Xpert

NOTE!
� For reinstallation, your Laptop/PC must be linked to Internet via Windows Mobile Device 

Center or ActiveSync. One of these applications must be installed before proceeding.

Device Xpert installation files are on the SD card of Field Xpert. After a clean reset, they must 
be reinstalled in Field Xpert’s device memory and licensed again. 

1. Perform a clean reset: see Field Xpert Operating Instructions BA01202S/04/en
– The installation routine starts automatically on completion of the reset.

2. Field Xpert now asks for the internet connection to be established
– After connecting up to Windows Mobile Device Center or ActiveSync, 

click OK to proceed
– If it is not possible to establish an internet connection, the DD library will not be

updated and licence will not be reactivated automatically during the installation
routine. This must be done afterwards by hand, see Chapters 3.1.3 and 3.1.4.

3. The Proxy Configuration prompt appears
– If Field Xpert is to work with a proxy server enter Y and tap on OK 

otherwise enter N and tap on OK: the procedure now continues with Step 4
– Enter the Proxy Address and Proxy Port, confirming each entry with OK
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4. Using the internet connection, Field Xpert:
– Synchronizes the DD library
– Activates the license
This may take several minutes.
– If there is no internet connection this must be done afterwards by hand, 

see Chapters 3.1.3 and 3.1.4.

5. Field Xpert now pairs the Bluetooth modems
– For the HART Bluetooth modem, continue with Step 6
– For the HART Bluetooth and FFblue modems, continue with Steps 6 and 7
– For the FFblue modem, continue with Step 7

6. The HART modem prompt appears
– Switch on the HART Bluetooth modem and tap on OK
– Tap on OK to proceed to the selection screen
– In selection screen, tap on a modem and the tap on Next - the modem is paired

– Refresh updates the modem selection list
– If you have only Device Xpert HART, proceed with Step 8, otherwise Step 7

7. The FOUNDATION fieldbus modem prompt appears
– Switch on the FFblue modem and tap on OK
– Tap on OK to proceed to the selection screen
– In selection screen, tap on a modem and the tap on Next - the modem is paired

– Refresh updates the modem selection list
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8. Field Xpert now completes the installation
– A pop-up indicating that installation procedure is finished appears for 15 s,

after which a restart is initiated

9. Field Xpert reboots and starts up with the standard home screen
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4.2 Connection problems

All types of connection (Bluetooth modem, FXA520 and SFC162) should function without 
any faults or interruptions. If you notice any communication failures (values in the DD are 
colored red), please check your connections as shown below.

NOTE!
� All chapters numbers in the table below refer to Operating Instructions BA01202S/04/en, 

Field Xpert Hardware 

Fault Cause/Remedy

VIATOR Bluetooth 
modem does not 
connect

Communication error
� Modem or Field Xpert Bluetooth communication not switched on
� Batteries flat (< 10 %), see BA01202S/04/en - exchange batteries
� Communication stalled: Switch off Field Xpert and the modem, wait 10 seconds, 

switch on the modem, wait 10 seconds, switch on Field Xpert
Communication settings incorrect
� Check that the VIATOR modem has been selected,
� Check that the modem has been correctly configured, see BA01202S/04/en
� Check that the modem has been selected as default modem

FFblue Bluetooth 
modem does not 
connect

Communication error
� Modem or Field Xpert Bluetooth communication not switched on

– Modem sleeps if there is no traffic over a specific period (10 min)
– To awaken, disconnect from fieldbus, then reconnect to fieldbus

� Batteries flat (< 10 %), see BA01202S/04/en - exchange batteries
� Communication stalled: Switch off Field Xpert and disconnect the modem, wait 10 

seconds, reconnect the modem, wait 10 seconds, switch on Field Xpert
Communication settings incorrect
� Check that the FFblue modem has been selected
� Check that the modem has been correctly configured, see BA01202S/04/en
� Check that the modem has been selected as default modem

Fieldgate FXA520 
does not connect

Communication error
� Fieldgate FXA520 or Field Xpert WiFi communication not switched on
� Communication stalled: Switch off Field Xpert and the FXA520, wait 10 seconds, 

switch on the FXA520, wait 10 seconds, switch on Field Xpert
Field Xpert communication settings incorrect
� Check that Fieldgate FXA520 has been selected
� Check that Fieldgate FXA520 has been correctly configured, 

see BA01202S/04/en
Fieldgate FXA520 communication settings incorrect
� Check that the Ethernet network addresses have been correctly set up
� For more information see the operating instructions of Fieldgate FXA520

Gateway 
SFC162does not 
connect

Communication error
� Gateway SFC162 or Field Xpert WiFi communication not switched on
� Communication stalled: Switch off Field Xpert and the SFC162, wait 10 seconds, 

switch on the SFC162, wait 10 seconds, switch on Field Xpert
Field Xpert communication settings incorrect
� Check that gateway SFC162 has been selected
� Check that gateway SFC162 has been correctly configured, see BA01202S/04/en
SFC162 gateway communication settings incorrect
� Check that the gateway SFC162 is operating as visitor
� Check that the Ethernet network addresses have been correctly set up
For more information see the operating instructions of gateway SFC162

USB connection of 
Field Xpert to a PC 
does not work

Windows Mobile Device Center/ActiveSync connection lost
� Disconnect and reconnect USB port
� Restart PC
� Choose one of the two options that now appear

– We recommend "Connect without configuration"
WiFi connection operating in parallel
� Set up ActiveSync to accept a parallel wireless connection
� If necessary consult your IT specialist
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4.3 Software problems

4.4 DD updates

If it becomes necessary to synchronize the DD library, e.g. if there are new devices on the 
market, this be can done by using the DD update service (Software Update Service) with the 
order number SFX301 provided by your local Endress+Hauser Sales Center. You will be 
requested to give the Endress+Hauser serial number of your Field Xpert.

The DD Update Service will be enabled for your specific Field Xpert, so that the user can 
synchronize the library.

Detailed information on the ordering structure is available:

�  In the Product Configurator on the Internet page: www.endress.com È Select country 
È Products È System components & recorders È Device configurator È Field Xpert 
SFX100/Field Xpert SFX350/Field Xpert SFX370 È Product page function: Configure 
this product

�  At your Endress+Hauser Sales Center: www.addresses.endress.com

Fault Cause/Remedy

Device Xpert freezes Software error
� No software error - function requires time to complete
� Communication stalled: Switch off Field Xpert and the modem/gateway, wait 10 

seconds, switch on the modem/gateway, wait 10 seconds, switch on Field Xpert
� Device Xpert crash: perform a soft reset, see BA01202S/04/en

Communication settings incorrect
� Check that a modem is paired and ready to use, see Chapter 6.8 of Operating 

Instructions BA01202S/04/en

All values in 
parameter list go red 

Communication interrupted
� Check the modem/gateway, see BA01202S/04/en

It is not possible to 
change parameters

Field Xpert is write protected or wrong device access level is in use
� Disable write protection or set device access level to e.g. Service mode

(this requires the entry of the service code)

Service menu cannot 
be seen

Wrong device access level is in use
� Set device access level to e.g. Service mode

(this requires the entry of the service code)

Changes to 
FOUNDATION 
fieldbus parameters 
cannot be 
downloaded

Operator error
� Set the Block Target Mode to OOS and try again, see Chapter 3.3.6

Dynamic variables do 
not update

Normal operation
� To maintain a low level of communication on the HART protocol, dynamic 

variables as per the initial setting are not updated. You can change these 
manually: 
– Select View=>Configuration=>Options
– Select Poll all Dynamic every X seconds, and enter the desired number of 

seconds
– Select OK to close and confirm.
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For your notes
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